W2 .NET Developer

Remote • Posted 1 hour ago • Updated 1 hour ago
Contract W2
12 Months
No Travel Required
Remote
$65/hr
Company Branding Image
Fitment

Dice Job Match Score™

🔢 Crunching numbers...

Job Details

Skills

  • .NET
  • ASP.NET
  • C#
  • IoT
  • Microsoft SQL Server
  • Microsoft Azure
  • Grafana
  • DNS
  • Cosmos-Db
  • MQTT
  • Kubernetes

Summary

W2 .NET Developer

We are seeking a highly skilled W2 .NET Developer to join our remote team on a rolling contract basis. This role offers a competitive rate of $65 per hour. The ideal candidate will have a strong background in .NET development, with a preference for those who have previously worked at Walmart, Amazon, Microsoft, or PayPal. If you are an ex-Walmart employee, please provide the name of your former manager and ensure you have a 6-month cooling-off period since your last engagement. Note that we do not accept CASPEX.

Responsibilities

As a .NET Developer, you will be responsible for:

  • Developing, maintaining, and enhancing.NET applications using C# and .NET Core.
  • Designing and implementing RESTful APIs using ASP.NET Core Web API.
  • Working with Azure IoT Hub SDK to integrate IoT solutions.
  • Utilizing Entity Framework Core for database interactions.
  • Containerizing applications using Docker and deploying them on Kubernetes.
  • Writing unit tests using xUnit, Moq, and Fluent Assertions.
  • Implementing logging and monitoring solutions using Splunk, Azure Log Analytics, and Grafana.
  • Ensuring the security and scalability of applications using Azure services and best practices.
  • Collaborating with cross-functional teams to deliver high-quality software solutions.

Requirements

<>Required Skills
  • Programming Languages/Tools: C# (C# 14), ASP.NET Core Web API (ASP.NET Core 10), Azure IoT Hub SDK (Azure IoT SDK for.NET)
  • Development Framework: .NET 10 (LTS) /.NET Core, Entity Framework Core 10, OpenAPI for service contracts
  • Deployment Framework: Docker, Kubernetes, Helm
  • Unit Tests Framework: xUnit (v3), Moq (or NSubstitute), Fluent Assertions (or AwesomeAssertions), Fakes, Testcontainers (integration tests)
  • Version Control System: Git, GitHub Enterprise, GitHub Actions
  • Storage: SQL Server / Azure SQL Database, Azure Blob Storage, Azure Cosmos DB
  • Cloud services (Microsoft Azure): Azure IoT Hub, Azure IoT Hub Device Provisioning Service (DPS), Azure IoT Operations (Azure Arc-enabled), Azure App Service, App Service Environment (v3), Azure Kubernetes Service (AKS), Azure App Configuration, Azure Key Vault, Managed Identities, Azure Event Hubs (Kafka-compatible endpoint)
  • Logging: Splunk, Azure Log Analytics, Azure Application Insights, OpenTelemetry, Serilog
  • Monitoring and Alerting: Prometheus, Grafana, MMS, XMatters, Azure Monitor
  • Authentication: Identity and Access Management (IAM), Microsoft Entra ID (formerly Azure AD), OAuth 2.0 (RFC 9700 security best practices, PKCE; OAuth 2.1 draft), SAML 2.0, OpenID Connect 1.0, JWT (RFC 7519/RFC 9068), mTLS (RFC 8705), PingFederate, Service Registry
  • Architectural Patterns, Design Patterns and Styles: Client-Server, REST, event-driven / publish-subscribe, CQRS, Clean Architecture, TDD, Strategy pattern
  • Knowledge on protocols: HTTP/2, MQTT (3.1.1 / 5.0), AMQP 1.0, gRPC; OPC UA is an added advantage
  • Knowledge on Networking (TCP/IP, DNS, VLANs, VPN/private connectivity), PKI (X.509 certificates, certificate lifecycle management), TLS 1.3 (RFC 8446) and OWASP Top 10
<>Preferred Skills
  • Hands-on Experience in developing custom ASP.NET Core middleware and using built-in rate limiting, health checks and output caching.
  • Hands on experience in Java
  • Good understanding on Azure IoT Edge architecture (IoT Edge 1.6 LTS) and components like IoT Edge devices, Edge Gateways, Edge Modules, Edge deployments etc.
  • Working experience in providing solution for stability, interoperability, portability, security and scalability of system architecture.
  • Knowledge on Azure Edge Infra activities along with Linux commands is an added advantage.
  • Azure Certifications like AZ-204 (Azure Developer Associate; replaces the retired AZ-203), AZ-400 (DevOps Engineer Expert) or AZ-305 (Azure Solutions Architect Expert)
  • Awareness of post-quantum cryptography readiness: NIST FIPS 203 (ML-KEM), FIPS 204 (ML-DSA) and FIPS 205 (SLH-DSA), with FIPS 206 (FN-DSA) in development; hybrid TLS key exchange and crypto-agility practices
  • Familiarity with Zero Trust principles and secure supply chain practices (SBOM, dependency and container image scanning)
Employers have access to artificial intelligence language tools (“AI”) that help generate and enhance job descriptions and AI may have been used to create this description. The position description has been reviewed for accuracy and Dice believes it to correctly reflect the job opportunity.
  • Dice Id: 91138897
  • Position Id: 9140081
  • Posted 1 hour ago

Company Info

About Spear Staffing

As the world’s first and largest specialized talent solutions and business consulting firm, we are a rapidly growing company with the potential to offer you a rewarding career. Our team comprises talented professionals with expertise in recruitment, talent acquisition, and career development. We collaborate to create innovative solutions and deliver extraordinary results.

We offer competitive salaries, benefits, and a collaborative work environment. Our culture is one of collaboration and respect, and we strive to create a positive work-life balance for our employees. Join our team and help us achieve our mission of positively changing people’s lives!

From flexible schedules to development opportunities, at Spear Staffing you’ll have the support you need to reach your goals at every stage of your career. Explore some of the reasons why many of our employees have been with us for 10, 15, 20 years or longer.

Contact the job poster
Shubham Singh

Shubham Singh

Recruiter @ Spear Staffing

Create job alert
Never miss an opportunity! Create an alert based on the job you applied for.